Home Phoronix Phoronix Forums X.Org Videos From FOSDEM 2008

RadeonHD IRC Logs For 2009-6-09

Search This Log:


Nightwulf|work: hi all
Zajec: yangman: may I ask you where are you from?
Zajec: curosicity coming from your name :)
yangman: Zajec: currently in Vancouver, Canada area. born in China, spent a chunk of my childhood in Japan, but living in Canada since '96
Joy: has attached two monitors and can't get three different pictures :)
yangman: Joy: laptop?
Zajec: PLLs/CRTCs limitation?
Zajec: I think you would need 3 PLLs/CRTCs for 3 different pictures
yangman: 3 CRTCs anyway
yangman: Joy: in any case, getting more than 2 different pictures isn't something that's supported in the consumer grade radeons. 2 max
Joy: ah, that makes sense, windows wouldn't let me do that either
Joy: i can only get vga_1 to display the same as dvi_d-1
yangman: a CRTC takes the image in memory and outputs signals that a monitor can display. you can only have as many unique output images as there are CRTCs
Joy: imagines the situation where he could activate his Intel card, also in the laptop, simultaneously with the Radeon :)
Joy: i'm guessing that's not supported for a plethora of reasons either
yangman: indeed not
MostAwesomeDude: Well, not really a plethora.
Joy: i'm guessing lack of power
MostAwesomeDude: It's only three or four reasons.
Joy: and lack of distinction for accessing the physical ports
MostAwesomeDude: Which are all really really silly.
MostAwesomeDude: More like, it's really tricky to turn on and off video cards.
Joy: made harder by the fact it's all welded onto the same board? :)
yangman: that's not much of an issue. the BIOS getting in the way is most of the time, though
ElAngelo: when can we expect a new release?
yangman: new release would be a good idea
yangman: there's a few outstanding bugs in the pipe still
udovdh: hello,
udovdh: any caveats, tips, etc w.r.t.
udovdh: using RS690 or hd3500 via hdmi to a TV?
udovdh: i.e.: 50 Hz 720x576 in PAL-land?
yangman: no tv-out support yet
udovdh: no...
udovdh: but the card has DVD-D
yangman: oh, HDMI. sorry, missed that
udovdh: with an adapter I can get hdmi, right?
yangman: theoretically
udovdh: that goes to the TV
Zajecx: udovdh: yes
udovdh: and then I need videomodes which the TV will take
Zajecx: udovdh: you need sound via HDMI, right?
udovdh: the tv is HDprepared
udovdh: so has a normal tube
udovdh: but is not scared of some higher resolution. (?!)
Zajecx: udovdh: err? :)
Zajecx: maybe it's just 720p
udovdh: dunno, doubt it
Obscene_CNN: so do you have a HDMI to TV converter?
udovdh: then it would have a HD label somewhere
udovdh: no
Zajecx: Obscene_CNN: DVD-D to HDMI converter as I undesrstand
udovdh: tv has hdmi input
Zajecx: DVI-D
udovdh: and I am thinking about an ITX board with ATI video
udovdh: for mythTV etc
udovdh: so would that setup be abl;e to drive the TV
Zajecx: udovdh: yes
udovdh: once I get the right videomode
Zajecx: udovdh: even with sound over HDMI
udovdh: (how?)
udovdh: cool
Zajecx: udovdh: err, nothing special... you just plug cable and use xrandr --output DVI-D_1 --auto
udovdh: asuming my TV handles that better than my sound-less monitor
udovdh: and assuming the dvi-d - hdmi adapter doesn't interfere
Zajecx: udovdh: playing sound in soundless monitor may be hard ;) :P
udovdh: Zajecx, looks simple
udovdh: Zajecx, yes but the video got issues when sound was enabled
udovdh: on the card
udovdh: but ok, thanks for the help
Zajecx: ouch... would be nice to report this, Christian would check this probably
udovdh: so I might get me such a board later this year
udovdh: Zajecx, they know
udovdh: it's a non issue for me, monitor has no speakers
udovdh: and timing is not right with audio in the signal
Asgeir: hello guys, do you know how can I do to make my radeon hd 6450 work with a 2.6.29 GNU/Linux kernel ?
Asgeir: I'm under Gentoo, and portage's ati-drivers don't support this kernel
Asgeir: The free driver isn't working, so i'm without xorg for now
MostAwesomeDude: Asgeir: Did you remember to "eselect opengl xorg-x11"?
Asgeir: hum
MostAwesomeDude: Also pastebin your Xorg.0.log
Asgeir: ok
Asgeir: all it's at http://asgeir.free.fr/upload/gen/
Asgeir: I use X -config /root/xorg.conf.new
Asgeir: (thanks)
MostAwesomeDude: Hm.
MostAwesomeDude: Weird, the modesetting's not working. Could you try with radeon instead of radeonhd?
Asgeir: hum, yes
Asgeir: hum, it seems I need to recompile xorg, eh ?
MostAwesomeDude: No.
MostAwesomeDude: You should emerge xf86-video-ati, if it's not already on your system.
MostAwesomeDude: And then change "radeonhd" to "radeon" in your xorg.conf, and try again.
Asgeir: hum
Asgeir: thanks :D
Asgeir_: hum
Asgeir_: Black screen of death
Asgeir_: forced reboot
MostAwesomeDude: Hm.
MostAwesomeDude: Do you have a new Xorg.0.log ?
Asgeir_: yes, it's updated now.
Asgeir_: oh shit
Asgeir_: # Load "dri"
Asgeir_: maybe it's that...
MostAwesomeDude: Possibly, but probably not.
MostAwesomeDude: I'd really like to see your Xorg log though.
Asgeir: you'll be pleased to know it's not Load "dri" which caused the error.
Asgeir: sorry, I didn't see anything from "o shit"
Asgeir: *I haven't seen
MostAwesomeDude: Hm.
MostAwesomeDude: Which version of xf86-video-ati are you using?
Asgeir: 6.12.2
MostAwesomeDude: Hm. So it should all work.
Asgeir: to configure radeonhd, I followed wiki instructions, and compiled drm.ko and radeon.ko from git
Asgeir: maybe it's that ? :o
MostAwesomeDude: No.
Asgeir: damn.
MostAwesomeDude: Again, seeing your log with radeon instead of radeonhd, would be useful.
Asgeir: euh
Asgeir: I use radeon...
Asgeir: http://asgeir.free.fr/upload/gen/Xorg.0.log is up to date
Asgeir: it doesn't find r300_dri.so
MostAwesomeDude: You're not using an r300, so that's okay.
MostAwesomeDude: Comment out your accelmethod in your xorg.conf, and see if that works.
Asgeir: hum
Asgeir: it's done, in fact
Asgeir: xorg.conf.new is not up to date
Asgeir: accelmethod is exa, dri is on
Asgeir: ah
Asgeir: sorry
Asgeir: I try
Asgeir_: dammnit
MostAwesomeDude: Still nothing?
Asgeir_: yes, still black screen that force me to reboot
Asgeir_: Ctrl+Alt+Backspace does not work :o
Asgeir_: and the log is still the same
rektide: NoZap is the option in xorg.conf, at least it used to be
FallenWizard: Asgeir_: because it's disabled
Asgeir_: oh
FallenWizard: I did it with a HAL rule
FallenWizard: terminate:ctrl_alt_bksp
Asgeir_: hum
Asgeir_: rektide: DontZap, no ?
rektide: uh yeah that
Asgeir_: thanks :D
Asgeir_: I don't know why it cried about r300_dri.so
Asgeir_: hd 4650 isn't supported by r300 but by r700 if I remember well
Asgeir: rah
Asgeir: Ctrl+Alt+Backspace doesn't works corretly : it reboots computer, now -_-'
Asgeir: but I don't care.
Asgeir: I tried disabling all dri stuff
Asgeir: but the error is still the same
FallenWizard: wtf
FallenWizard: it shouldnt reboot the pc
FallenWizard: distro?
Asgeir: Gentoo xd
Asgeir: hum, I don't understand why but
FallenWizard: hmm
FallenWizard: kernel?
Asgeir: xorg loads DRI even if Option "DRI" "on" isn't specified.
FallenWizard: R6xx - R7xx needs an updated kernel DRM
Asgeir: gentoo 2.6.29-r3
FallenWizard: it's in 2.6.30
Asgeir: with git's drm and radeon.ko
FallenWizard: then it should work
Asgeir: following wiki's instructions.
FallenWizard: strange
Asgeir: yes :D
FallenWizard: nopaste for /var/log/Xorg.0.log please
FallenWizard: your*
Asgeir: http://asgeir.free.fr/upload/gen/Xorg.0.log
FallenWizard: oh
FallenWizard: (EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/r600_dri.so failed (/usr/lib/xorg/modules/dri/r600_dri.so: cannot open shared object file: No such file or directory)
FallenWizard: I have the same
FallenWizard: but It works anyway
FallenWizard: but it still doesn't explain why your computer crashes with CTRL+Alt+Backspace
Asgeir: :D
Asgeir: I don't care if it crashes when Ctrl+Alt+Backspace in fact ; except if it can resolve my other problèm ^^
FallenWizard: hmm
FallenWizard: maybe MAD can help you, he is the Xorg Pro
MostAwesomeDude: Nope, I'm stumped.
MostAwesomeDude: agd5f: ^^ any ideas?
MostAwesomeDude: You *did* try disabling EXA, right?
Asgeir: yes :D
Asgeir: commenting the line Option gnagna "exa"
Asgeir: hum, and the ati-drivers aren't up to date to work with 2.6.29 I presume...
FallenWizard: yes
agd5f: Asgeir: does disabling DRI fix it? Option "DRI" "False"
FallenWizard: the patch doesn't work completly
FallenWizard: it will spam your syslog
Asgeir: I will try DRI False
Asgeir: and if it don't works, I'll let the computer off :D
Asgeir: good night guys, and thanks for all
Obscene_CNN: have you tried radeonhd?
Asgeir: yes ^^
T`2: agd5f, hi.. there?
agd5f: T`2: hi
T`2: agd5f, https://bugs.freedesktop.org/show_bug.cgi?id=21963
T`2: agd5f, will there be a fix in radeonhd too? i have the same issue on radeonhd on 3450HD
T`2: agd5f, i could file a different bug with the same description in the radeonhd component if you want
agd5f: T`2: I'll fix it in both drivers once I've figured out what the problem is
T`2: agd5f, thanks!
jvd: i just set up radeonhd on a new machine, and it's awesome
jvd: 1080p with mplayer's xv output works great
jvd: it's an rs780
jvd: with hdmi out
jvd: thanks! :P