Home Phoronix Phoronix Forums X.Org Videos From FOSDEM 2008

RadeonHD IRC Logs For 2009-6-11

Search This Log:


Nightwulf|work: hi all
wirry: doofe christel
wirry: wrong chan :/
jmho: hi, I've got corrupted fonts on 2560x1600 and 1920x1200, but not on 1600x1200. If I take screenshots, the screenshots are not corrupted. I think this is maybe a cable problem, but don't know what could be wrong there.
jmho: so, sr, perhaps a little offtopic, but does anyknow know where I can perhaps ask?
bridgman: jmho; guess it could be one of two things - either your cable isn't handling dual-link properly (since the transition from single to dual link is somewhere around where you are seeing problems) or there's some kind of memory underflow problem causing corruption in what gets scanned out to the display
bridgman: can you describe the corruption ?
jmho: bridgman: I could make a picture
bridgman: sure, or just words... vertical lines, horizontal lines, no lines but the text looks funny, does the corruption change over time, does it change when you move the pointer, is the corruption different around the pointer etc...
jmho: bridgman: text looks funny and is in large parts unreadable
jmho: it does not change if I move the mouse
jmho: corruption is imho not cursor related
bridgman: same corruption all across the screen ? does it look at all like every second pixel is missing ?
bridgman: horizontally ?
jmho: yes, same corruption all across the screen, let me check for the pixels
jmho: no, it does not look like every second pixel is missing
jmho: in the meantime I made photos, any idea where I can upload?
bridgman: maybe open a ticket at bugs.freedesktop.org and attach to the ticket; reasonably small pic zoomed in tight on the pixels if possible
jmho: this is 1600x1200, not corrupted: http://img199.imageshack.us/img199/8554/img2481o.jpg
jmho: and this is 2560x1600, corrupted: http://img199.imageshack.us/img199/4497/img2482y.jpg
bridgman: I'm on 21kbps dial-up so 24MB pics take a while ;)
bridgman: even compressed ;)
jmho: bridgman: hehe ;)
jmho: regarding the possibility that it is a dual link dvi issue, how can I check if the cable is a dual link cable? according to the vendor it should be
airlied: jmho: all the DVI pins will be in it on both eds
airlied: and hopefully joined between
jmho: ah ok, I can check the ends
jmho: the cable looks like a dual link cable
jmho: and as it came with the monitor it should be ok (I hope)
bridgman: which GPU ?
bridgman: which GPU ?
jmho: rv730
jmho: just found in wikipedia that even single link dvi should be good for 1920x1200@60, so I guess it's not a cable issue
Nightwulf|work: has got a single link dvi cable connected to his acer 241wd (24", 1920x1200)
jmho: I just tried radeonhd from git, but there DRI does not seem to work in contrast to 1.2.5 from debian sid
jmho: I get: (EE) RADEONHD(0): [dri] CP_INIT failed in Xorg.log
jmho: ah wait, firmware is missing
chorxoc: Does DRI mean 3D support?
wirry: no
chithead: dri means direct rendering
abby: does the new radeonhd have 3D support
jmho: abby: not yet
abby: oh alright, I was wondering why I couldn't play games :)
abby: Is it being actively developed? If not, I'd like to help.
abby: I'm gonna checkout the repository regardless
chithead: abby: the work is currently being done in the r6xx-rewrite branch of mesa
jmho: I get this warning:
jmho: rhdAtomAllocateFbScratch: FW FB scratch area not located at the end of VRAM. Scratch End: 0x44fec VRAM End: 0x10000000
abby: mesa, ah that's right
abby: thanks chithead
jmho: is it something to worry about?
ctmjr: Hi, i would like to try this (agd5f's 3d code) http://www.phoronix.com/forums/showthread.php?t=17603, my question is should i remove the current radeonhd driver installed from git, and start all over, or just remove the drm portion.
Obscene_CNN: ctmjr, a fresh git pull might be safer but your probably safe with 1.2.5
ctmjr: Obscene_CNN, ok thank you will see what happens.
Obscene_CNN: yw
Obscene_CNN: wilturn, not to be a pain, but did you try to apply my patch yet?
udovdh: hello
Obscene_CNN: hi udovdh
udovdh: helping another user to make radeonhd work (now, via telephone...)
udovdh: fedora 11 with a f10 radeonhd_drv...
Gralamin: Anyone around who could help with a weird problem?
Gralamin: I'll take that as a no. I'll be around for a while, at least...
yangman: Gralamin: just ask away. if someone that can help show up, they'll answer
Gralamin: Oh, okay then
uzi18: it is possible to watch tv on radeonhd?
Gralamin: I'm trying to set up RadeonHD on my laptop (Toshiba Satellite A350-01N), which has an ATI Mobility 3650 HD.
yangman: uzi18: no tv-out support, but HDMI works
uzi18: think of tvtime
Gralamin: I'm following this: https://help.ubuntu.com/community/RadeonHD , but I get an error that I'll CP in just a second
Gralamin: "Ubuntu is running low-graphics mode
Gralamin: The following error was encountered. You may need to update your configuration to solve this.
Gralamin: (EE) RADEONHD(0): rhdAtomLvdsDDC: Unknown Record Type: f8
yangman: uzi18: oh, tv-in. no, afaik
Gralamin: (EE) RADEONHD(0): D1CRTCDisable: Failed to Unsync CRTC 1
Gralamin: (EE) RADEONHD(0): rhdALLIdle: Unable to stop CRTC: Cannot idle MC"
uzi18: yangman, i have tuner card but need - support for YUY2
yangman: uzi18: the Xv implementation for radeonhd supports YUY2
yangman: Gralamin: which version of radeonhd do you have installed?
uzi18: yangman, so how to enable xvideo?
Gralamin: I followed the "Building radeonhd" command, so I would assume whatever the newest is. (command was: cd ~/ git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-radeonhd cd xf86-video-radeonhd ./autogen.sh --prefix=/usr make sudo make install )
yangman: uzi18: you need 2.6.30 kernel for r6xx/r7xx. for r5xx it should just work on the latest version
yangman: Gralamin: I *think* it's a known issue, but I don't remember the bug entry
uzi18: yangman: just kernel?
yangman: uzi18: which card?
uzi18: yangman, hd4850
yangman: uzi18: 2.6.30 kernel with the radeon DRM module, then enable DRI on xorg.conf, and also set AccelMethod to EXA. see: http://yangman.ca/xorg.conf
Gralamin: yangman: I posted this on the phoronix forums already. So maybe someone on there will eventually post a solution
uzi18: youngman, thx
yangman: Gralamin: file a bug or send a message to the maillinglist
uzi18: ups
uzi18: yangman, :) thx
Gralamin: yangman: How would I go about doing that?
uzi18: yangman, 1.2.5 is enught?
yangman: http://www.x.org/wiki/radeonhd#head-28145e1625df634e3cdff6691fa85523f92af18e
yangman: uzi18: yeah
yangman: Gralamin: actually, before you do that, can you pastebin your xorg.0.log please? I might be able to find the bug if I can see the whole log
Gralamin: yangman: Sure. Let me go grab it
Gralamin: http://pastebin.com/m65952e97
yangman: Gralamin: that log is with the vesa driver. try Xorg.0.log.old
Gralamin: k
Gralamin: http://pastebin.com/ma649c14
yangman: Gralamin: I think it's a card quirk. go ahead and file a bug so it doesn't get lost
Gralamin: Alright
yangman: Gralamin: thanks for the bug. can you actually attach the log to the bug? it's best to keep everything together and not reply on 3rd party services
Gralamin: yangman: sure
yangman: thanks
Gralamin: Added
Obscene_CNN: I'm trying to help someone in a forum, Any ideas? http://forums.gentoo.org/viewtopic-t-770966.html
Obscene_CNN: he is getting screen corruption
yangman: Obscene_CNN: hard to say without seeing the corruption
Obscene_CNN: he is going to try and get a screenshot
Obscene_CNN: yangman, what sort of corruption did the cursor issues you fixed cause?
yangman: Obscene_CNN: cursor image getting garbled with changing static at certain positions on the screen
yangman: only affects the cursor
Obscene_CNN: okay, thanks
Obscene_CNN: yangman, Could I have you look at the last post in this thread? http://forums.gentoo.org/viewtopic-t-770966.html
yangman: Obscene_CNN: yeah, I'm sort of following it. either AGP breakage or WM using a feature that's still unimplemented
Obscene_CNN: okay, thanks. I just recomended he try Option "ExaNoDownloadFromScreen" and Option "ExaNoUploadToScreen"
Obscene_CNN: its probably AGP breakage
Kaapa: guys, need help
Kaapa: I'm desperate with the stupid fglrx driver
Kaapa: it screwed my install, now I'm trying to roll it bach
Kaapa: anyone knows what means the error AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed
chithead: this channel is for the open source radeonhd driver, visit #ati for fglrx support
Kaapa: I don't want fglrx support, I want to wipe it and isntall radeonhd :p
Kaapa: but if that place still is the best place, thanks
chithead: and unless you used the installer executable, you should be able to uninstall through your distro's package manager
Kaapa: that "unless" is tha bad part
chithead: probably you need to reinstall mesa or such, and get rid of all fglrx.* in /lib/modules
Kaapa: did that / did that
Kaapa: I'll look again for the mesa part and ask in my channels dist
jim_ec2: woohoo 2.6.30 released! compiled and ready to try 2d accelleration :o